RDM REST API (v14.3 or later)

  • 8 February 2024
  • 4 replies

Userlevel 3
Badge +3

Hello hive mind,

Has anyone out there who have RDM v14.3 or later, and successfully used the new RDM REST API feature?

We’ve upgraded our dev environment to v14.5.1 this week, I tried the REST API, and it keeps returning with “java.lang.Exception: Cannot access entity: address_type” error. (Was trying to query my entity called address_type)

I ensured my service account client has full access to the table. That service account client calls other API endpoints that I have built before on rdm-server and that authenticates fine.

I wonder what I’m missing. Anybody successful before and we can compare notes?



Best answer by Mario Georgiev 8 February 2024, 15:51

View original

4 replies

Badge +2

Hello May,

Please check the following things:


  • The services account has a correct prefix in front of its name. It should start with RDM_
  • The correct roles were assigned in the Service accounts roles for the client in Keycloak
  • This role has correct permissions in the RDM web application permissions tab
Userlevel 5
Badge +3

In addition to what Mario wrote it could be issue with permission sync. Please check that you see the service account user with appropriate roles in the Users part of the RDM web application permissions tab.

Userlevel 3
Badge +3

So we found out that my token client did not have “rdm” in the name.

Once we created a new token client starting with “rdm” it worked.

I was blind and did not see that part in the documentation.

Thanks folks for the help!

Userlevel 6
Badge +4

Great to hear everything is resolved now @maykwok_hamilton 😊