Transform file for Reading in Compatible time


(Jayant Singh) #1

Dear colleagues,
We are trying to modify logic in few of our components in a .mdc file. When we open the component, then we see the following error.

Please see the above error message.
As I understand, it is a version mismatch. So to upgrade the template, we tried the following approach:

Right click on the project name and choose Upgrade template.

update

But we get the above message that we are using the most recent template version and no update is required. May I know then why do we see the error while opening the components? Help is greatly appreciated


(Maksim Zhelyazkov) #2

Hello Jayant,

The message you received is not an error, this is expected behaviour. When you use files from older versions of our products you need to upgrade them. Clicking OK on this message will upgrade your component while keeping all its content.

Upgrading the project template only works if the project was an older version. In your case you probably just added the components/plans to an existing model project (that is already to the latest version).

If you want to update the added components/plans to correspond to the model project version please follow below instructions:

add the files to the project -> right click on the project -> Batch Actions -> Change versions.

You will see the list of all plans, components, etc. in the project and the versions they will become. Clicking finish will upgrade all of them to the current version of your product.

Kind Regards,

Maksim


(Jayant Singh) #3

Thank you Maksim, for your help. It was really helpful.


(Maksim Zhelyazkov) #4

Hello Jayant,

You are welcome. I am glad I could help you out.

Regards,
Maksim