RDM importer straight to published state


(Maksim Kim) #1

Is it possible to create initial data load which bypass applied workflow and makes all the records published?

For tables without workflow if you choose ‘confirm’ in RDM importer’s ‘Move to edit action’ it will publish the data.

If a table has workflow then ‘confirm’ sends the data to the first workflow state which is inconvenient for initial loads.


(Petya Minovska) #2

Hello Maksim,

It is not possible to bypass an applied custom workflow.
The only workaround that we could suggest is to try to “disable” the workflow for the purpose of the initial load, then “enable” it again. In order to achieve this, we would suggest you to follow the steps:

  1. Download the current configuration from the RDM system console;
  2. Extract the configuration and copy the workflow.xml file somewhere on your machine and backup it;
  3. Change the workflow.xml file in the following way:
    <?xml version="1.0" encoding="UTF-8"?> <workflow> <entities /> <emails /> </workflow>
    and replace it in the configuration archive;
  4. Reload the configuration;
  5. Load the initial data;
  6. Replace the workflow.xml file in the configuration with the original one you backed up;
  7. Reload the configuration.

Regards,
Petya