RDM application error


(Amey Gupte) #1

We are getting application error in RDM and are unable to start the web application. Logs are attached herewith. Has anyone experienced this before, and knows how to solve this issue? We tried restarting Ataccama and Tomcat servers, but that did not help.


(Amey Gupte) #2


(Dimitar Dikov) #3

Hi Amey,

I believe we solved this issue with your colleagues on a support ticket, here is the suggestion:
The reason for this issue is that RDM has a register where the information about tables is stored. Once the register is getting inconsistent with the actual content of the repository, the application always fails.

I suggest to DROP (not truncate) CS and TS tables in RDM repository - that’s where this technical information is stored - and redeploy the configuration. They should be re-created according to the current configuration, it should resolve the issue. However, please create a backup of your repository before doing that.

Let me know if this another problem.
Thanks,
Dimitar


(Amey Gupte) #4

Yes, this is resolved. Thank you.