MS SQL Connection error


(Alex Cook) #1

Ataccama newbie here, hopefully this is an easy one. I downloaded DQ Analyzer and am attempting to connect to a MS SQL Server DB to which I have no issues accessing with SSMS. I am getting a login error (see attached)…it appears that it’s mistaking my computer name (USNB170131UMA7E) as a server, even though I entered a hostname (URL), etc. It’s unclear to me why it’s doing that.

Any advice? It would be far preferable for me to connect directly to the DB than to export data.


(Victoria Tuktarova) #2

Hello Alex,

The issue might be caused by incorrect connection parameters.
Can you please also send us a screenshot of the whole ‘New Database Connection’ window? You can cover up username and password.

Regards,
Victoria


(Alex Cook) #3

Attached. It’s pretty simple, I entered the requested fields as I would if connecting from SSMS. Any thoughts?


(Victoria Tuktarova) #4

Hello Alex,

First of all let me clarify that this error is not connected to IDE. Most likely it is caused by driver or DB configuration. That is why I would ask you to check few things.

  1. Was there any changes in build itself and driver particularly?

  2. Please, check connection string settings (if possible you can send us the whole string). Manage – MS SQL – Edit.

  3. If settings are correct, you can try to copy/paste the connection string from SSMS to connection parameters directly.

  4. Moreover, changing server’s authentication mode may resolve this issue.

Let me know the results.

Regards,
Victoria


(Alex Cook) #5

This is an Azure SQL Database…does DQA support Azure SQL connections? That could explain the issue. This is not an on-prem SQL Server DB.


(Victoria Tuktarova) #6

Hello Alex,

Unfortunately, currently DQA does not support Azure SQL. But we are working on it. Please, check the list of supported databases below:

  • Oracle R9+
  • MS SQL 2005+
  • IBM DB2 9.7
  • Teradata 12.10, 13.10
  • IBM DB2 10.5
  • Sybase ASE 16.2
  • Sybase ASA 17
  • MySQL 5.7.11
  • Apache Derby 10.11.1.1
  • PostgreSQL 9.4.1

Regards,
Victoria


(Alex Cook) #7

Well, that explains why I can’t connect to it! Thanks for the update. As suspected, it was user (my) error.