Issues in DQA 11


(Vardan Shahinyan) #1

Hi, looks like Show Progress is not available by default in DQA 11, but it was there with DQA 9, 10. Is it possible to enable it in DQA 11?

Capture

Thanks,
Vardan


(Katrin Popova) #2

Hello Vardan,

Thank you for reporting this issue. Our development team has been informed. It would be fixed in the next release. I would like to mention that the release date has not been established yet.

I apologize for any inconvenience this may cause you.

Best regards,
Katrin Popova


(Vardan Shahinyan) #3

Thank you for prompt response Katrin, could you also take a look at one more issue please? When I try to abort execution, system aborts it abnormally resulting to NullPointerException, but it was fine in DQA 10 where result was “Execution aborted by user.”:

Best Regards,


(Katrin Popova) #4

Hello Vardan,

Both issues might be connected and would be investigated together.

Thank you for reporting them and once again, we apologize for any inconvenience caused.

Best regards,
Katrin Popova


(Vardan Shahinyan) #5

Thanks Katrin, please also take a look at below.

“Run Configuration…” window doesn’t open when I click on it after I exported run configurations from DQA 10 to DQA 11 through Import/Export functionality. However, at the same time “Run Configuration…” works for the .plan files in Tutorials project. Could you confirm please whether it’s a bug?

Thank you


Capture0


(Katrin Popova) #6

Hello Vardan,

Would it be possible to give me more information regarding these questions:

  • Could you please provide me with steps how to reproduce the issue?
  • What is the exact version of DQA from which you are exporting?

I would kindly ask you to open a new topic in Community when there is a need to discuss new question.

Best regards,
Katrin Popova


(Vardan Shahinyan) #7

Sure, sorry for that, currently just renamed topic name, for new questions will create new topics.

I export from DQA 10.5.1 64-Bit (JRE:1.7.0_67) to 11.1.1 64-Bit (JRE:1.8.0_112)

Steps to reproduce are following:

  1. Create a new .plan file in 10.5.1
  2. Setup custom Run Configuration like below:
    1
  3. Go to File > Export > Run/Debug > Launch Configurations and click Next
  4. Select newly created configuration, click Finish
  5. Open 11.1.1
  6. Copy .plan file from 10.5.1 to 11.1.1
  7. Go to File > Import > Run/Debug > Launch Configurations and click Next
  8. Select configuration file and click Finish
  9. Double click on .plan file in 11.1.1 and try to open Run Configuration…

(Katrin Popova) #8

Hello Vardan,

I was able to reproduce the issue. Please follow these steps:

  • Import Launch Configurations
  • Open Run Configurations of the given plan
  • On the left side, would be available all Launch Configurations
  • Choose the newly imported one and in Ataccama DQ Analyzer launch in Main XML field browse the new location of the given plan:

Please let me know if the provided solution is sufficient and do not hesitate to ask if you have any additional questions.

Best regards,
Katrin Popova


(Vardan Shahinyan) #9

Thank you Katrin, it worked. However, after import I couldn’t open Run Configurations for that particular plan, it just didn’t open. But when I opened it for other plan file then navigated to my configuration it worked.

The only problem now is that if I have many .plan files I will need to do it one by one for each of them right? Is there a way to specify one run configuration for whole project (for all plan files in particular catalog)?

Thank you,


(Katrin Popova) #10

Hello Vardan,

I would like to clarify that there is not a possibility to create one Run Configurations settings for a whole Project.

In addition, I have successfully reproduced the issue when Run Configurations becomes inactive. We would investigate it further. Meanwhile, possible workaround is, as you mentioned, to open Run Configurations through another plan.

Lastly, I would like to note that if the project folder has the same name and structure as in the previous version, it would not be necessary to change the path in Main XML field after importing Launch Configuration, because the path which is specified there is not absolute path.

Best regards,
Katrin Popova


(Katrin Popova) #11

Hello Vardan,

I would like to inform you that the Show progress and Terminate options in the Console were fixed and will be available in the next minor release of DQA.

Regarding the issue with Run Configurations after import of Launch Configuration, I would have to discuss it with the product owner and would give you an update as soon as I have more information.

Best wishes,
Katrin Popova


(Vardan Shahinyan) #12

Thanks a lot for the prompt feedback, Katrin !


(Katrin Popova) #13

Hello Vardan,

I have discussed with the product owner the issue with Run Configurations. It is due to incompatibility between versions. Using Launch Configurations of different versions could lead to serious errors. This is the reason why, we highly recommend setting manually Launch Configurations, not importing it.

Once again, thank you for reporting this issue and I apologize for any inconvenience caused.

Best regards,
Katrin Popova


(Vardan Shahinyan) #14

Thank you Katrin,

In that case either system should not allow to import that configurations or if it allows it should work :slight_smile:

Then may be it would be possible to add feature when launch Configuration will be added not for just particular .plan file but selectively for one or more .plan files which will allow to set one configuration for all profiles in my case.


(Katrin Popova) #15

Hello Vardan,

Thank you for your suggestion, we highly appreciate it.

I want to apologize, because I might have mislead you with my comment from November 10.
If you would like to set memory for Launch Configuration. There is a possibility, if there is no need explicitly to increase the allocated memory for a specific plan, to reserve more memory for all your executing plans, as follows:

  • Open Window > Preferences > Ataccama DQ Analyzer > Launching.
  • Change the value of the Default memory for launch configuration (MB), for example to 1024 or more

However, there could be a scenario when a very complicated plan may require more memory or performance optimization. In this case, the allocated memory for the plan could be increased as you did in Run Configurations>Runtimes>VM arguments.

Best regards,
Katrin Popova