How I can run Ataccama as 64 bits application?

How I can run Ataccama as 64 bits application???

Hello Alain,

Can you elaborate on the purpose and the use-case of running DQA in the 64-bit mode?

Hi Said.

We have a heap error in DQA.

The system said that there is not enough memory in the heap.

I try with -Xmx2048m -Xms256m otpions, but the error remain.

An article in Internet said that if we can run 64 bits mode, it helps.

Or do you have another option??

thanks Said!

Hi Alain,

Thank you for information.
In general, you should not have any troubles running DQA in 32-bit mode.
If you receive an error while executing a plan, try this solution.
It should help.

If it will not help, please, provide more details such as when the error occurs, what are you trying to profile, the number of records you are trying to profile and the error log.

thanks, but is not working.

we are trying to profile > 1,400,000 records

can you do a TeamViewer session?

thanks

Hi

The system failed at record number : 1,146,487

The log, said:

26.04.2016 21:50:13 [INFO] Current status: Reading data (pass 1/2) - 1146487 records read
26.04.2016 21:51:10 [FATAL] Error running monitor.
java.lang.OutOfMemoryError: Java heap space
26.04.2016 21:51:39 [INFO] Current status: Reading data (pass 1/2) - 1146487 records read
Exception in thread “Thread-26” 26.04.2016 21:51:57 [FATAL] Error running monitor.
java.lang.OutOfMemoryError: Java heap space
java.lang.OutOfMemoryError: Java heap space
26.04.2016 21:51:59 [INFO] Current status: Reading data (pass 1/2) - 1146487 records read
26.04.2016 21:52:11 [INFO] Current status: Reading data (pass 1/2) - 1146487 records read
Exception in thread “Thread-28” java.lang.OutOfMemoryError: Java heap space
26.04.2016 21:52:26 [INFO] Current status: Reading data (pass 1/2) finished - 1146487 records read
26.04.2016 21:52:26 [INFO] Current status: Computing profile (pass 2/2) - 20% complete
26.04.2016 21:52:40 [INFO] Current status: Computing profile (pass 2/2) - 20% complete
Exception in thread “Thread-29” java.lang.OutOfMemoryError: Java heap space
26.04.2016 21:52:53 [INFO] Current status: Computing profile (pass 2/2) - 20% complete
26.04.2016 21:52:56 [INFO] Current status: Computing profile (pass 2/2) - 20% complete
26.04.2016 21:52:59 [INFO] Current status: Computing profile (pass 2/2) - 20% complete
26.04.2016 21:53:01 [INFO] Current status: Computing profile (pass 2/2) - 20% complete
26.04.2016 21:53:01 [FATAL] Not enough memory to run the plan file.[STEP A2Clientes_T3_PVMANALI_Agrupada[Jdbc Reader]]
26.04.2016 21:53:01 [FATAL] Internal error occurred during run of the plan: Java heap space[STEP A2Clientes_T3_PVMANALI_Agrupada[Jdbc Reader]]
26.04.2016 21:53:01 [FATAL] Task ‘A2Clientes_T1_PVMCLIEN_Agrupada’ failed.
java.lang.OutOfMemoryError: Java heap space
26.04.2016 21:53:01 [INFO] Stopping runtime…
26.04.2016 21:53:03 [INFO] Current status: Computing profile (pass 2/2) - 20% complete
26.04.2016 21:53:03 [INFO] Current status: Computing profile (pass 2/2) - 20% complete
26.04.2016 21:53:03 [INFO] Finished!

I did the Xmx parameter trick 1024m, but nothing happened.

Can you help ??

Hi Alain,

Thank you for sharing the error.
It seems that 1 GB is not enough to profile 1,400,000 records.
Can you try using the -Xmx2048m parameter in order to reserve 2 GB for the plan?

Let us know if it worked for you.

Hi Said.

Yes, I put the parameter, but Ataccama raised an error (this machine have 32 GB of RAM and Windows 10 x 64 bits)

and

Hi Alain,

Thank you for the details.
Let me offer you another solution.
If it will not work, we will organise a web session.
Is it suitable?

The solution:

  • Set the parameters in the DQA.ini file to the default values;

    -vm
    jre/bin
    –launcher.XXMaxPermSize
    256m
    -vmargs
    -Xms40m
    -Xmx256m
    -Xss512k

  • Go to Window -> Preferences -> Ataccama DQ Analyzer -> Launching and set the Default memory for launch configuration (MB) parameter to 1024;

  • Click on Runtime Configuration for your plan and specify -Xmx1160m in the VM argument box under the Runtimes tab. Then click on Apply -> Run.

Hi Said.

When I try to run with -Xmx1160 the system raise the error

Error occurred during initialization of VM
Could not reserve enough space for object heap

The max value accepted is 1024m

Please, let me know when we can do the web session.

Currently I am at GMT-5

The current machine configuration is

Thanks!

Dear Alain,

Before we organise the web session, can you share the plan with us?
Moreover, do you have a 64-bit Java Runtime Environment installed on your PC?

Dear Alain,

If you have the 64-bit Java Runtime Environment installed, you can use it to run the plan with more than 1 GB of allocated memory.

To define a new Java Runtime Environment, open Run Configuration for your plan, navigate to Runtimes tab and click on Installed JREs….
In the Preferences window, click on Add…, choose Standard VM, click Next and specify the directory with the 64-bit Java Runtime Environment by clicking Directory….

You should see something similar:

Click on Finish, set your new Java Runtime Environment as default and click on OK.

Choose the new Java Runtime Environment from the drop-down list, define the VM Argument, click on Apply -> Run.

It should resolve the issue that you are facing.

Sure!

Already sent in separated cover.

(I dont have 64 bits java installed on this machine)

thanks

Solved, thanks by your support!