Export to HTML not finished

Hi Team

I am running a large profiling project.

In this moment, I am runing DQA with Java 64 bits, and my previous issues has been solved.

But, now, when I am trying to export the profile, the system start, create several files, but the process stop without any errors.

Reviewing the file, the .profile.html is created empty, and the others files, are created without format (table format).

Any idea??

Dear Alain,

Is it possible to share the profile file for analysis?

Sure!

Sent in separated cover.

Best regards

Hi Said.

Any news about this?

thanks!

Hi Alain,

We are working on it.
As soon as we have details, we will update the status.

Hi Alain,

Your profile file contains a lot of data.
Can you try increasing value of the -Xmx parameter in the dqa.ini file to 1024 and try to export the profile again?
Please note, after changing the value of the -Xmx parameter, you need to restart DQA.

the -Xmx parameter should look as follows:

-Xmx1024m

Hi Said.

I have -Xmx6150…, and not working, but not raise an error.

thanks

Hi Alain,

Are we talking about the -Xmx parameter in the dqa.ini file or about Runtime parameter in the Run Configuration window?

We were able to export your profile to HTML, using -Xmx1024m in the dqa.ini file.

Please, let us know whether it worked.

Hi Said.

No, is not working on dqa.ini

The system raise this error

I try with -Xmx512m, and the error is not raised, but the exporting is not working properly.

My current .init looks like this:

-vm
jre/bin
–launcher.XXMaxPermSize256m
-vmargs
-Xms40m
-Xmx512m
-Xss512k
-Djava.library.path=C:\Ataccama DQ Analyzer 9\runtime\lib\jdbc\mssql\auth\x64\

Please, let me know if I can do anything else.

thanks

Hi Alain,

I would say that it is strange.
Can it be related to the OS you are running?
Let’s try increasing the -Xmx parameter in the dqa.ini file to 700m

-Xmx700m

I increase to 700m, but the process not finished.

I am using windows 10.

I think that is something related to Java, is like is not releasing the memory…, but I dont know.

Any advise??

Hi Alain,

We will try to address this issue during the web session.
I will communicate all the relevant information via email.

Thanks Said.

Finally is working, I add this parameter to my Run Configuration

-XX:+UseParallelOldGC

the final configuration looks like

-Xmx7168m -d64 -XX:+UseParallelOldGC

I supposed that Ataccama creates a lot of objects, during the export profiling and is not calling the GC on time, or something like this (at this point I can only guess).

thanks by your wonderful support and your amazing knowledge plus a great service attitude

Hi Alain,

Thank you for the input.
We are glad that the issue is resolved.