DQD Engine is missing in DQD Deploy Configuration Workflow


(Jayant Singh) #1

Hello colleagues,
I am trying to configure a workflow to deploy the configuration to DQD using the Admin center. Here is the configuration of my workflow;

image
image

As we can see it is showing a cross mark indicating, missing engine name. Meanwhile, when I start the admin center, here is what we see, w.r.t the workflow,

I have two questions; first why is there a red cross on my workflow icon indicating
a missing engine name, though the configuration stat says OK in the admin center.

Next question is, do we need to have an input to the DQD Configuration workflow.

If it helps, here is the screen shot from my serverconfig file;
image

Help is greatly appreciated.Thanks in advance.


(Katrin Popova) #2

Hello Jayant,

The Deploy DQD Configuration workflow task requires to be executed on the server. You should not worry about that it stays with a red cross in the IDE. Please also refer to this documentation.

Regards,
Katrin


(Jayant Singh) #3

Thaks for the davice. It helps.
Along the same lines, I have another query. I tried to make my Deploy DQD Task run based on a different condition, check for existence of file. please see the image;

image

The CHECK FOR COCLL has following configuration;
image
where CO_CLL is string defined as "T:\\Data Processing\\CDO\\DQ Rules\\CLL data\\2018 Mar\\CO_CLL_201803.csv".
But when we try to run it on the server, we get following error message;
ERROR : (@Deploy DQD Configuration@NORMAL) Invalid link definition at index 1: unknown link input task 'CHECK FOR COCLL'.

I am not sure, what is meant by Invalid link definition. Help/advice is greatly appreciated. thanks


(Katrin Popova) #4

Hello Jayant,

Could you please send me your plan, so I could take a look?

Regards,
Katrin


(Jayant Singh) #5

Good afternoon!
Thanx for helping me. Shall I attach the plan here, or is there a secure link to which I can upload my plan?

Please let me know.

Jayant.


(Katrin Popova) #6

Hello Jayant,

I have sent you the link to our secure upload portal on your email. Please send me the workflow, so I could review it.

Thank you,
Katrin


(Jayant Singh) #7

Thanks for sharing the link. But I am not being able to log into it using my 5/3 network password. May I know which password is supposed to be used?

Help is appreciated.


(Jayant Singh) #8

Good afternoon!
Thanks for the information. I did upload the workflow, 14ALLP_Deploy.ewf.

Feedback is appreciated.


(Katrin Popova) #9

Hello Jayant,

Could you please pass the CO_CLL variable like this: T:\Data Processing\CDO\DQ Rules\CLL data\2018 Mar\CO_CLL_201803.csv and share the results.

Regards,
Katrin


(Jayant Singh) #10

Thanks for your suggestion. As advised, the following change was done:

new_address

But the error message is still the same; unknown link input task.

Moreover, will it be okay to give he address in above fashion? As per the documentation, we have to escape the backslash. Let me know if I am getting it wrong.


(Katrin Popova) #11

Hello Jayant,

Could you please remove the spaces in the id of the task CHECK FOR COCLL and try again? For example, you can rename it to check_for_cocll.

Keep me posted,
Regards,
Katrin


(Jayant Singh) #12

Hello,
Thanks for your suggestions. I did the requested modification,
took_out_space

But the error persist, I am wondering is it a bug or something, because in my opinion spaces is not an issue. I have a similar situation testing for existence of file at allocation, and it is working fine, please see fig below.

I tried to imitate the settings for CO_CLL, but in vain. And to update you, I am escaping the backslash as advised in the documentation to make the string look like an address.

Can you kindly help? thanks


(Jayant Singh) #13

Hello
I did copy the workflow given by you and it works. Now I am really confused, because I am not seeing any significant difference between them.
Can you kindly help me to understand what is happening here?

thanks


(Katrin Popova) #14

Hello Jayant,

The issue is the spaces in the ID of the workflow task. It is a bug that we will fix. You can test it yourself, just add a space and it will reproduce the error “unknown link input task”.

Regards,
Katrin


(Jayant Singh) #15

Tanks for your help. I can see it, would have not thought of it.
Another question, I am thinking about is whenever we generate the project, the workflow configuration in serverconfig file gets commented. Then, we need to uncomment it and add the workflow information, so that we can see the workflow in the admin center.

Is that the way it is built to function or we have a workaround here.

Advice is appreciated.


(Katrin Popova) #16

Hello Jayant,

If you are using the example (template) dqd.serverConfig and dqd.runtimeConfig xml files, this happens because everytime you regenerate it gets to its default configuration. That is why I would advice you to place your configuration in the default.serverConfig.xml and default.runtimeConfig.xml file located in [installation folder]/runtime/server/etc/. Please review this documentation.

Best regards,
Katrin Popova


(Jayant Singh) #17

Thanks for your explanation.It is so kind of you.

I went through the documentation mentioned above and understood few points.

An as trial, I did make the changes, i.e. workflow configuration in the default.serverConfig.xml. Once I clicked on Save, Reload, and Generate, as expected the changes in dqd.serverConfig got commented.
image

But the changes in default.serverConfig are existing.

That is good, as expected. But now in the admin center, we don’t see the section on workflows anymore;
image

As far as I understand, when we make changes in the default files, it is not applicable to only one DQD project, but to all the projects. But we can’t see the workflow details in the admin center any more. Can you kindly give some advice?

Thanks.


(Katrin Popova) #18

Hello Jayant,

I guess you do not see it because you use the start script from the model project. If you right-click on the script and select Open with Text Editor, you would see that the script is pointing to the dqd.serverConfig.xml, so you should change it to use the default.serverConfig one:


The other way is to use the start script located in runtime/server directory.

Regards,
Katrin


(Jayant Singh) #19

Thanks, it works. Appreciate your advice.