DQD Deploy Config


(Ra Li) #1

Trying to deploy a DQD config to my localhost to test out. However, when I perform the “server_deploy_configuration” I get the error below:

29.06.2018 09:45:59 [FATAL] Cannot refreshConfiguration because configuration is changing now, engine state is DATAMART_VERSION_MISMATCH
Press any key to continue . . .

Any ideas how this issue can be resolved?

Thanks in advance,


(Katrin Popova) #2

Hi Ramzi,

Have you performed recently an upgrade of DQD? If yes, what steps have you performed?

Regards,
Katrin


(Ra Li) #3

Hi Katrin- I’m not aware of performing any upgrade to DQD.


(Katrin Popova) #4

Hello Ramzi,

Usually the error “Datamart version mismatch” appears when the Datamart was created in a different version than the web application or Admin center is. Or it might have happened that during deployment of the configuration you interrupted the process and it ended up in “Datamart version mismatch”. Could you please compare in the database the internal table Datamart version and the version of the Admin Center, just to exclude the reason is not that the Datamart was created in older version. In the Admin Center you can check the version in the bottom left corner:

Regards,
Katrin


(Ra Li) #5

Hi Katrin- My admin center shows 11.3. Where can I find the database version?


(Katrin Popova) #6

Ramzi,

Database_version is an internal table in the database. In my case:

Regards,
Katrin


(Ra Li) #7

Hi Katrin- Below is what I have:

image

I’m also using IDE 11.3


(Katrin Popova) #8

Hello Ramzi,

Could you please send me your dqd-config.xml that you are trying to deploy? Please verify it is the one that the server_deploy_configuration is using.

Regards,
Katrin


(Katrin Popova) #9

Hello Ramzi,

Thank you for sending me your configuration file. It seems fine to me. I would like you to check one more thing, could you please verify if the connection string for the datamart is configured correctly? The point is to check if the Admin Center and DQD dashboard are connected to the right database:

  • For the DQD Dashboard web applications please check /META-INF/context.xml
  • For the Admin Center in runtimeConfig

Were you able to deploy configuration via the script before? And did you perform some specific steps before the error started appearing?

Regards,
Katrin


(Ra Li) #10

Both files look to have the proper information.

I was able to deploy the configuration before. My entire computer was migrated to cloud and so the path to Ataccama folder has changed however, all other Ataccama applications are working fine.

Regards,