Cannot find SMTP resource


(Jayant Singh) #1

Hello colleagues,
We are attempting to add the email option to my workflow. To this end we have implemented a SMTP server.

Implementation: SMTP
Name: Mail53
Host: Mail53.53.com
Port: 25

Then in the email option of my workflow, following details have been added.

image

But the workflow is in INVALID state.

Can I get some help? I already have a SMTP server defined, but the error persists. Can I get some help, what might be wrong here?


(Victoria Tuktarova) #2

Hello Jayant,

Have you configured the SMTP connection in the .runtimeConfig file?

Kind regards,
Victoria


(Jayant Singh) #3

Thanks for the suggestion. I will make sure to try it and update.
Meanwhile, can I get the link to the documentation page with above details?

thanks


(Victoria Tuktarova) #4

Hello Jayant,

Sent the link via email.

Kind regards,
Victoria


(Jayant Singh) #5

Thanks for the link. Appreciate it. One question I had was regarding the crypted password. Is it default password?
How is this password different from the password defined in the server details?

server_details

Since I am running on local machine, can I enter an arbitrary password here?

Thanks


(Victoria Tuktarova) #6

Hello Jayant,

Could you please clarify what do you mean by “the crypted password. Is it default password?”. In .runtimeConfig file you can define either crypted or non-crypted password. The instruction on how to crypt your password is also provided in the documentation I sent to you.

Any server/source/etc configuration defined in IDE should correspond to .runtimeConfig file. Hence, the password should be the same as you define in runtime configuration.

Please, let me know if you have any further questions.

Kind regards,
Victoria


(Jayant Singh) #7

Thanks for the reply. By default password, I meant, whether the password should be same as the one defined in the link, you had provided. For the time being, we are using the default password provide in that link.
If I am getting it correctly, the password in the runtimeconfig should be identical to the server details. In the server details, shall we enter the password, AES:5rNM3amiDCHjOSo3PRdF4scrNEHMhzeKmMr8TlRjLbFvaoDyY18kR8SpS1TXUm/o. Or shall we enter the password as 5rNM3amiDCHjOSo3PRdF4scrNEHMhzeKmMr8TlRjLbFvaoDyY18kR8SpS1TXUm/o.

Can you kindly confirm? thanks in advance.


(Victoria Tuktarova) #8

Hello Jayant,

You can use encrypted password in configuration files like Runtime Configuration and Server Configuration. In IDE you should define not crypted password, otherwise you won’t be able to connect.

Kind regards,
Victoria